PDA

View Full Version : Out for coffee



Basil
01-04-2008, 01:35 AM
I have found that I receive this message when posting a reply in the CL.


You don't have permission to access /newreply.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I am able to post elsewhere. I am able to read CL.

Basil
01-04-2008, 01:41 AM
OK plot thickens. I have tried to PM KB with the refused text. It won't me PM the message either. I guess there is something in the text that it doesn't like.

It appears the offending word in my post was 'databse'. But I can post it here. :hmm:

Garrett
01-04-2008, 06:17 AM
I guess they've finally woken up to you Gunner.

Kevin Bonham
01-04-2008, 12:43 PM
Apparently I'm allowed to say "database" but Gunner isn't. I didn't get the PM.

There was something else weird a little while back where a particular combination of words caused some strange issue. May be something like that again.

Rincewind
01-04-2008, 04:05 PM
Apparently I'm allowed to say "database" but Gunner isn't. I didn't get the PM.

There was something else weird a little while back where a particular combination of words caused some strange issue. May be something like that again.

There are some words which are banned due to the risk of SQL insertion attack.

Gunner, if you want to email me the text I'll see if I can work it out.

Basil
01-04-2008, 04:14 PM
There are some words which are banned due to the risk of SQL insertion attack.

Gunner, if you want to email me the text I'll see if I can work it out.
Thanks Rince

I worked around the problem by changing the word 'database' to 'directory' in the penultimate paragraph of my last post in the tea house.

FWIW, I guessed the reason for the error generation described at post #1 was something along the lines of what you have said. Working on that assumption, I pasted my text, paragraph by paragraph, (after having copied the entire text to a text editor) into the post - saving the post as I went along.

When it became apparent that the penultimate para was the offending one, it was easy enough to identify possible suspect words.

Basil
01-04-2008, 04:16 PM
I didn't get the PM.
Yes, the PM refused to send, also generating the same error message.


There was something else weird a little while back where a particular combination of words caused some strange issue. May be something like that again.
I recall, but selective to some users only IIRC.

Rincewind
01-04-2008, 04:35 PM
When it became apparent that the penultimate para was the offending one, it was easy enough to identify possible suspect words.

I suspect the problem was the proximity of the word "create" and "database" in the one sentence.

In fact without the quotation marks the previous sentence exhibits the same problem.

Basil
09-05-2009, 10:45 AM
Just adding to the knowledgebase, I tried to post a moment ago and received one of the standard database errors.

I removed the words "I select" and then the post was permitted.

ER
09-05-2009, 10:50 AM
(...) I removed the words "I select" (...)
You did well, certain words as the underlined above belong to Eclectic's intellectual territory and not for common :P :owned: use!!!

Rincewind
09-05-2009, 12:39 PM
Here is a link to Microsoft's SQL Server documentation on the reserved keywords for that particular dialect of SQL.

http://msdn.microsoft.com/en-us/library/aa238507(SQL.80).aspx

Any words on the list could cause problems but I note that SELECT is one of the more common SQL statements you come across in practice.

Kevin Bonham
09-05-2009, 02:39 PM
Troubleshooting thread for this nonsense here (http://chesschat.org/showthread.php?t=9683)