Results 1 to 4 of 4
  1. #1
    CC Candidate Master slyall's Avatar
    Join Date
    Jun 2013
    Location
    Auckland, New Zealand
    Posts
    72

    Chesschat slow or just me?

    Just wondering if other find the site really slow at times. My problem is that pages take a minute or two to load or don't load at all (tcp timeout error, and take 2-3 retries to work). This seems to happen quite often here but not on other sites.

    On the other hand when I do test from places like webpagetest.org everything looks good and the pages load in a couple of seconds (even from the New Zealand site). Tests from command line and other browsers on my PC seem to vary, sometimes fast but they too timeout every now and then.

    Just me? Just my provider (Spark ADSL, Auckland, New Zealand) ? or others as well?

    This has been happening since forever (months at least).

  2. #2
    CC Grandmaster Garrett's Avatar
    Join Date
    Jun 2006
    Location
    the City
    Posts
    3,176
    First step would be to try a different browser, or clear browser cache.

    Good luck !

  3. #3
    CC Grandmaster ER's Avatar
    Join Date
    Jul 2006
    Location
    Melbourne - Australia
    Posts
    11,869
    Very fast Chesschat loading in Canberra!

    as Garrett says ...


    Quote Originally Posted by Garrett View Post
    First step would be to try a different browser, or clear browser cache.

    Good luck !
    ACF 3118316
    FIDE 3201457

    https://aus2020.chesschamp.net/

  4. #4
    CC Candidate Master slyall's Avatar
    Join Date
    Jun 2013
    Location
    Auckland, New Zealand
    Posts
    72
    Like I said already tried another browser. Cleared cache anyway and tried on another PC (also at home) with the same result.

    Anyway I was debugging a bit if any of this helps:

    1. At home approx 10% of requests (for the same .js element) fail. What seems to happen is the tcp connect just hangs for between 5 seconds and till whatever the timeout is. This happens even with static elements.

    2. From my US machine I didn't see any failures. But I don't ever seem to hit the machine(s) with Frontpage extensions installed.

    3. I notice that the requests served by the server(s) with Frontpage install have http keepalives while those from the other server(s) don't. Not sure if this means much since I don't know the setup at the other end.

    4. I notice that firefox is aggressively re-fetching even the static elements. It will cache them for a minute of so but still requests them. There isn't any explicit logic set with expire headers so I'm not exactly sure where this is coming from. Perhaps setting more explicit expire tags for some objects will help. Browser expire logic is always a little weird.

    5. However a good thing is that fetching with "If-None-Match" on the etag seems to work so not problem there.

    Here are a couple of requests, if they are useful. Note the first one hits the "frontpage" machine and gets Keepalive and Age headers while the other doesn't (even though it is reusing the same keepalive connection I think).

    > GET /clientscript/vbulletin-core.js?v=421 HTTP/1.1
    > User-Agent: curl/7.37.1
    > Host: www.chesschat.org
    > Accept: */*
    > If-None-Match: "1201cb-cadc-4e5b1af02a1c0"
    >
    < HTTP/1.1 304 Not Modified
    < Date: Mon, 06 Apr 2015 10:41:28 GMT
    * Server Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/4.4.9 is not blacklisted
    < Server: Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/4.4.9
    < Last-Modified: Fri, 06 Sep 2013 07:06:55 GMT
    < ETag: "1201cb-cadc-4e5b1af02a1c0"
    < Accept-Ranges: bytes
    < Content-Type: application/javascript
    < Connection: Keep-Alive
    < Age: 0
    * Connection #0 to host www.chesschat.org left intact


    * Connected to www.chesschat.org (122.201.118.118) port 80 (#0)
    > GET /clientscript/vbulletin-core.js?v=421 HTTP/1.1
    > User-Agent: curl/7.37.1
    > Host: www.chesschat.org
    > Accept: */*
    > If-None-Match: "1201cb-cadc-4e5b1af02a1c0"
    >
    < HTTP/1.1 304 Not Modified
    < Date: Mon, 06 Apr 2015 10:41:32 GMT
    * Server Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 PHP/4.4.9 is not blacklisted
    < Server: Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 PHP/4.4.9
    < ETag: "1201cb-cadc-4e5b1af02a1c0"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So like, hey ChessChat...
    By ChoiSeulKi in forum Non-Chess
    Replies: 13
    Last Post: 04-12-2010, 03:40 PM
  2. What will become of ChessChat?
    By Aaron Guthrie in forum Non-Chess
    Replies: 9
    Last Post: 15-12-2007, 09:41 AM
  3. Live at the BBQ (slow loading)
    By jeffrei in forum Games and Analysis
    Replies: 35
    Last Post: 18-09-2004, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •